CE301 RS485

Гарик

CE301 RS485

Сообщение Гарик » Чт ноя 15, 2012 8:55 am

Здравствуете.
Имеется счетчик CE301 R33 043-JAZ (2012 №008840066001344). Проблема заключается в том что при подключении к нему по выставленным уставкам порта связи ответам является сообщение что Формат принятых от устройства данных не соответствует протоколу. По монитору обмена ясно что запросы идут и ответы тоже.

Ответ
DrtRS232.dll
15.11.2012 11:48:07.646
125 127 }
Запрос
DrtRS232.dll
15.11.2012 11:48:10.349
47 63 33 13 10 /?!..
Ответ
DrtRS232.dll
15.11.2012 11:48:10.349
127 
Запрос
DrtRS232.dll
15.11.2012 11:48:13.053
47 63 33 13 10 /?!..
Ответ
DrtRS232.dll
15.11.2012 11:48:13.053
127 122 z
Запрос
DrtRS232.dll
15.11.2012 11:48:15.756
47 63 33 13 10 /?!..
Ответ
DrtRS232.dll
15.11.2012 11:48:15.756
127 127 
Ответ
DrtRS232.dll
15.11.2012 11:48:16.021
127 127 127

На счетчики при разных настройках сети выпадает ошибка Err05, Err04. Чаще Err05.

По форуму видел что данный вопрос был про ошибку Err05. Ваша рекомендация поставить галку напротив опроса на начальной скорости результат не дал. Испробовал все ваши рекомендации по настройке сети в программе AdminTools 3.4b, результата нет.

Внешнее питание подано для интерфейса(9В), на адаптер то подано(24). Галочка что использовать как Serial port в настройках ком порта стоит.


Прошу ответить по возможным нюансам в подключении счетчика к программе.

Гарик
Сообщения: 5
Зарегистрирован: Чт ноя 15, 2012 11:13 am

Сообщение Гарик » Чт ноя 15, 2012 11:20 am

Забыл уточнить что протокол выбран Протокол ГОСТ - МЭК 61107-2001 с параметрами 2500 3 20 и галка обмена на начальной скорости.
Канал связи RS232 (7,E,1), пробовал управление RTS ставил прямое и прямое аппаратное, результат такой же.

Гарик
Сообщения: 5
Зарегистрирован: Чт ноя 15, 2012 11:13 am

Сообщение Гарик » Чт ноя 15, 2012 12:37 pm

Проверены настройки и подключения в соответствии с обсуждением следующих тем форума:
Питание интерфейса RS485 CE301 R33 043-JAZ Чт Апр 01, 2010 5:30 pm
CE301 и Err 05 Пн Июн 28, 2010 2:20 pm

Так же просмотренные схожие темы...
На данный момент результат печальный ((

Концерн «Энергомера»
Сообщения: 7721
Зарегистрирован: Ср сен 18, 2002 3:51 pm
Контактная информация:

Сообщение Концерн «Энергомера» » Пн ноя 19, 2012 4:58 pm

По монитору ясно только, что запросы к счетчику идут (Err04, Err05 говорит о том, что не корректные), а в ответ приходит только мусор. Галочка «Обмен на начальной скорости» не помогает, так как обмен до стадии перехода на рабочую скорость не доходит.

Настройки канала связи:
    COM порт,
    Скорость - установить скорость соответствующую начальной скорости счетчика (посмотреть на ЖКИ индикаторе),
    Четность - чет,
    Биты данных - 7,
    Стоповые биты – 1,
    Эхо – выкл.,
    Управление RTS – прямое аппаратное.

На рисунке пример успешной авторизации со счетчиком :
<img src="http://www.energomera.ru/images/forum/20121119/image002.jpg">
Можно попробовать вкл./выкл. галочку в диспетчере устройств: Serial Port > Advanced Settings> Use FIFO buffers. Но скорее всего проблемы с линией.

Рекомендации:
Проверьте подключение счетчика в соответствии с рисунком 3.4 руководства по эксплуатации счетчика
Интерфейс счетчика (9-12 В, не менее 100 мА контакты 15(22) 14(23) см. рисунок 3.4 РЭ)
Попробуйте подключить резисторы растяжки.

Гарик
Сообщения: 5
Зарегистрирован: Чт ноя 15, 2012 11:13 am

СE301

Сообщение Гарик » Вт ноя 20, 2012 12:07 pm

Все рекомендации по настройке портов и каналов связи выполнены, соответственно тень подозрения падает на внешние адаптера. Как COM порт используется Moxa 1150 в режиме RS232, уставки выставлены 9600 7, Even , 1 , none. Счетчик не насраивается но канал связи выставлен 5555. Конвертор RS485-RS232 выполнен по следующей схеме:

Гарик
Сообщения: 5
Зарегистрирован: Чт ноя 15, 2012 11:13 am

Сообщение Гарик » Вт ноя 20, 2012 12:16 pm

Сылки на изображение не пропустил фильтр, оставшаяся часть сообщения в файле

rusfolder.com/33698730

Заранее благодарю за ответ

Гарик
Сообщения: 5
Зарегистрирован: Чт ноя 15, 2012 11:13 am

Сообщение Гарик » Пн ноя 26, 2012 8:05 am

Благодарю за ответы, очень помогли, особенно скрин правильного обмена)
Использован адаптер Moxa в режиме RS485 2W с настройками ком порта 7 Е 1, в программе вы ошиблись, для правильной постановки сообщения нужно использовать 7 Е 1 прямое.

Благодарю за терпение.

Вернуться в «Счетчики электроэнергии (темы и сообщения до 31 декабря 2012 года)»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 3 гостя